Users Developers
Home / Forums / In-Portal CMS / Installation & Upgrade / Install fails after database config page / Topic Posts

In-Portal Forum

This is a place for users of In-Portal to ask questions, discuss various topics, and interact with other members of the In-Portal Community. Please report bugs through the Bugs Team (not the Forum). If you are interested in contributing or joining one of the many Teams for In-Portal, please check out the Contribute section of the website.

In-Portal Forum

Install fails after database config page (7)

Posted: 02/08/2010 12:48:14 AM

Reply Quoted  

When trying to install I get to the DB config page, fill in the info and submit, then get a page with the following message -

Fatal error: Class 'kApplication' not found in /hsphere/local/home/jeffprit/ on line 1002

There seems to be a connection as tables get created.

The host advised I set PHP mode to PHP_cgi5 which I have done.

Have tried install a few times but get exactly same error message.

Posted: 02/08/2010 10:57:47 AM

Reply Quoted  

Hello there,

Thanks for joining In-Portal Forums and downloading In-Portal.

Let's start with listing your folders so we can make sure thing is missing. Would please list them here.


Posted: 02/08/2010 6:54:53 PM

Reply Quoted  

Hi Dmitry

Folders are -
cgi-bin (existed)
cp (existed)
css (existed)
images (existed)
webalizer (existed)

Files are -
index.html (existed)
login.html (existed)

Posted: 02/11/2010 10:49:01 AM

Reply Quoted  

Hi again,

Sorry for some delay with getting back to you.

Here is something we should try next:

1. Drop all the tables that were created during unsuccessful installation. In other words - make sure it's clean.

2. Enable In-Portal DEBUGGER. Here you can find information (2nd post) on how to do this -

3. Try running your installation again and copy past the Fatal Errors that will be displayed by Debugger here.

Also, if you feel comfortable be glad to assist you with installation directly. Just email us at support [at] in-portal [dot] com with installation details.


Posted: 02/11/2010 6:39:03 PM

Reply Quoted  

Hi Dmitry

Enabled the debugger, though couldn't see anything at bottom of page. F12 did bring up the debugger though.

I followed your instructions, dropped tables and tried again and it is the same.

The same error showed up in the debugger under the Script tab.

Fatal error: Class 'kApplication' not found in /hsphere/local/home/jeffprit/ on line 1002

Posted: 02/12/2010 1:29:24 PM

Reply Quoted  

Hello Jeff,

Looks like you are missing bunch of files. In particular under core/kernel/ folder (ie. application.php and others).

Here is a link to Repository browse -

As you can see there is more files.

I would recommend carefully reuploading all In-Portal and In-Link files again. Note that you have correct folder structure, but some file are missing.


Posted: 02/16/2010 1:54:18 AM

Reply Quoted  

Hi Dimitry

I removed everything, unzipped locally and reuploaded everything. Tried again and it installed fine.

Seems like when I unzipped on the server it didn't like it.

Thanks for your help.