Users Developers
Home / Forums / In-Portal CMS / Need Help! / Design Mode Not loading correctly / Topic Posts

In-Portal Forum

This is a place for users of In-Portal to ask questions, discuss various topics, and interact with other members of the In-Portal Community. Please report bugs through the Bugs Team (not the Forum). If you are interested in contributing or joining one of the many Teams for In-Portal, please check out the Contribute section of the website.

In-Portal Forum

Design Mode Not loading correctly (3)

Posted: 04/12/2011 9:51:05 AM

Reply Quoted  

Running 5.1.2
inlink innews inbulletin installed.

using the advanced theme.
when browsing the website in admin, then switching to Design Mode the poppup loads, but sometime is just about blank, or it gives me this error in red.

One or more fields on this form has an error.
Please move your mouse over the fields marked with red to see the error details.
File Contents - Failed to restore template "

Is design mode supposed to be working for the advanced theme? It looks like it is not finding the right path for the tpl files...

PS I should add, I just looked at your demo site admin and when in design mode using the default theme that you have loaded when on any other page besides the home page I get the same error...???

Design mode does not seem to be working... it would really be a great help if it did!

Any help would be appreciated.

Posted: 04/12/2011 11:28:22 AM

Reply Quoted  

For "Design Mode" to work you should set write permissions recursively on "themes" folder in your In-Portal installation.

This is needed, because template editor, used for page editing will save changes directly into TPL files you've been editing.

Posted: 04/12/2011 1:23:48 PM

Reply Quoted  

Thanks Alex but that did not work.. I even set the whole themes directory to 777 re-cursing into the sub dirs...

tried again and it did the same thing.

besides the initial error statement I posted above, I should add it also posts this

Filename: /themes/advanced/.tpl
Element Position: invalid block name - invalid block name

What can I do?
I wish it was as easy as making the folders writeable!